Mini-ats102.ru

ООО “Мультилайн”
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как найти, выделить цветом или удалить повторяющиеся значения в таблице Excel

Как найти, выделить цветом или удалить повторяющиеся значения в таблице Excel

Привет всем. Сегодня я хочу рассказать вам, как найти повторяющиеся значения в Excel и что с ними можно сделать. Если вам приходиться работать с таблицей, где есть дублирующиеся данные, то хотелось бы знать, как их отыскать. Именно этим, в этом уроке, мы и займемся.

Для примера я возьму вот такую таблицу Эксель. Взял список людей из какой-то группы вКонтакте, разделил имена и фамилии, и наделал несколько ячеек с дублями.

Выделение дубликатов из одного столбца

Если вы хотите выделить дубликаты из одного столбца в Google Таблицах, вам нужно сначала выбрать столбец, в котором вы хотите найти дубликаты.

Выбор столбца в Google Таблицах

Выделив столбец, нажмите « Формат»> «Условное форматирование» в строке меню.

Параметр меню «Условное форматирование»

Если в этом столбце уже активировано условное форматирование, щелкните Добавить другое правило. В противном случае вы можете отредактировать правило, которое отображается в данный момент.

Добавление правила условного форматирования Google Таблиц

Нажмите поле « Формат ячеек, если» и выберите « Пользовательская формула» в раскрывающемся списке.

Выбор правил условного форматирования настраиваемой формулы

Введите = countif (A: A, A1)> 1 в поле Значение или формула или замените все вхождения буквы A в формуле выбранным столбцом.

Например, чтобы применить форматирование к столбцу M, ваша формула будет иметь вид = countif (M: M, M1)> 1.

Добавление правил настраиваемой формулы

Вы можете установить стиль форматирования самостоятельно, выбрав параметры цвета и шрифта. Вы также можете использовать один из различных предустановленных стилей форматирования, кликнув текст по умолчанию в параметрах стиля форматирования , а затем выбрав один из предустановок.

Изменение стилей условного форматирования

Кликните Готово, чтобы добавить правило условного форматирования. Все повторяющиеся ячейки должны теперь отображаться с выбранным выделением.

Используем фильтрацию

С помощью фильтрации, можно скрыть дублированные данные, при этом значения не удаляются — их можно вернуть в любой момент.

Чтобы провести форматирование и найти повторяющиеся значения таким образом следует:

  1. Определить необходимую область.Выбор области
  2. На закладке «Данные» установить фильтр.Установка фильтра
  3. В том же блоке сортировки и фильтрации нажать «Дополнительно» для запуска расширенного фильтра. Проверить выбранный диапазон и установить галку «Только уникальные записи».Только уникальные записи
  4. После выполнения процедуры, дубли будут скрыты, а фильтрации уже не будет.Скрытие дублей
  5. Для возврата скрытых значений, нужно нажать кнопку «Фильтр».Включение фильтра
Читайте так же:
Можно ли восстановить литий ионный аккумулятор

Выделите повторяющиеся строки / записи

Это немного сложно.

Предположим, у вас есть набор данных, как показано ниже, и вы хотите выделить все повторяющиеся записи.

В этом случае запись будет дубликатом, если она имеет точно такое же значение в каждой ячейке в строке (например, в строках 2 и 7 в приведенном выше примере).

Причина, по которой это немного сложно, заключается в том, что теперь вам не нужно проверять отдельные ячейки. Вы должны проверить всю строку и выделить только те строки, в которых повторяются все ячейки.

Но не волнуйтесь, это не так уж и сложно.

Ниже приведены шаги по выделению повторяющихся строк с использованием условного форматирования:

  • Выберите набор данных (без заголовков)
  • Выберите в меню опцию Формат.
  • В появившихся параметрах щелкните Условное форматирование.
  • Нажмите на опцию «Добавить другое правило».
  • Щелкните раскрывающееся меню «Форматировать ячейки, если», а затем выберите параметр «Пользовательская формула есть».

Вышеупомянутые шаги выделят все записи, которые повторяются в наборе данных (как показано ниже).

Как это работает?

Этот работает так же, как наш первый пример (где мы просто выделили ячейки в столбце, в котором были дубликаты).

Но поскольку есть целая строка, которую нам нужно сравнить со всеми другими строками, мы объединили содержимое всех строк и создали одну строку для каждой строки.

Следующая часть формулы создает массив строк, в котором объединено все содержимое ячеек в строке (выполняется конкатенация с использованием знака амперсанда).

Этот массив используется в формуле Countif, и используемое условие снова представляет собой объединенную строку, которая имеет все значения в строке. Это делается с использованием следующих критериев:

Теперь это преобразовано в простую конструкцию типа столбца, в которой функция COUNTIF проверяет, сколько раз эта объединенная строка повторяется в созданном нами массиве строк.

В результате будут выделены все повторяющиеся записи.

Как сравнить столбцы в Эксель

Одна из особенностей приложения — возможность в Эксель сравнить столбцы (два и более) на факт отличий и различий, а после вывести результаты в виде подсвечивания цветом. Ниже рассмотрим, как правильно сделать эту работу для разного количества столбцов.

При рассмотрении вопроса, как сравнить два столбца в Excel на совпадения / отличия, нужно сравнить информацию в каждой отдельной строчке на отличия и одинаковые параметры. Сделать такой шаг можно с помощью «ЕСЛИ». Формула вставляется в каждую строчку в соседнем столбике около таблицы Эксель, где размещены основные параметры. После создания записи для 1-й строки ее можно протянуть и копировать на другие строчки.

Если вас интересует, как сравнить столбцы в Excel на совпадения, используйте запись с соответствующей командой — =ЕСЛИ(A2=B2; “Совпадают”; “”). Бывают ситуации, когда необходимо сравнить два столбика и найти отличия. В таком случае используйте иную запись — =ЕСЛИ(A2<>B2; “Не совпадают”; “”). По желанию можно выполнить проверку на совпадения / отличия между двумя секциями с помощью одной формулы. Для этого используется один из следующих вариантов:

  • =ЕСЛИ(A2=B2; “Совпадают”; “Не совпадают”);
  • =ЕСЛИ(A2<>B2; “Не совпадают”; “Совпадают”).

При этом в таблице выводится информация о наличии совпадений или отличий.

Если стоит задача в Экселе сравнить столбцы с учетом регистра, применяется другая запись. Используйте — =ЕСЛИ(СОВПАД(A2,B2); “Совпадает”; “Уникальное”)

Альтернативный вариант

Существует еще один способ, как в Эксель сравнить два столбца на совпадения. Задача в том, чтобы определить повторяющиеся параметры в обоих столбцах. Здесь можно использовать упомянутую ранее функцию ЕСЛИ или СЧЕТЕСЛИ. Формула имеет следующий вид =ЕСЛИ(СЧЁТЕСЛИ($B:$B;$A5)=0; “Нет совпадений в столбце B”; “Есть совпадения в столбце В”). После ввода формулы производится проверка в строчке «В» на факт совпадений с данными в строке «А». При наличии фиксированного количества строк в Эксель можно указать определенный диапазон, к примеру, $B2:$B20.

Больше двух

По-иному обстоит ситуация, если нужно сравнить в столбцы в Excel, когда их больше двух. Программа позволяет сравнивать данные в нескольких столбиках по ряду критериев: находить строчки с одинаковыми значениями во всех или в двух столбцах. Если их больше двух, используйте функции ЕСЛИ и И. При этом сама формула в Эксель приобретает следующий вид — =ЕСЛИ(И(A2=B2;A2=C2); “Совпадают”; ” “). Как только программе удалось сравнить данные, в последней строке выводится информация о совпадении.

Если столбцов в Эксель более двух, рекомендуется использовать опцию СЧЕТЕСЛИ и ЕСЛИ. При этом сама команда приобретает следующий вид — =ЕСЛИ(СЧЁТЕСЛИ($A2:$C2;$A2)=3;”Совпадают”;” “).

Поиск совпадений в двух и более столбцах

Бывают ситуации, когда в Эксель необходимо сравнить несколько столбцов, но найти совпадения хотя бы в двух из них. В таком случае применяются опции ИЛИ и ЕСЛИ. Для решения задачи делается следующая запись в специальной графе =ЕСЛИ(ИЛИ(A2=B2;B2=C2;A2=C2);”Совпадают”;” “).

В случае, когда в таблице много больше двух столбцов, формула может быть слишком большой, ведь в ней нужно указывать параметры совпадения для каждой вертикальной секции таблицы. Чтобы оптимизировать процесс, нужно использовать другую функцию СЧЕТЕСЛИ. При этом полная запись будет иметь следующий вид: =ЕСЛИ(СЧЁТЕСЛИ(B2:D2;A2)+СЧЁТЕСЛИ(C2:D2;B2)+(C2=D2)=0; “Уникальная строка”; “Не уникальная строка”).

В этой формуле условно выделяется две части. В первой СЧЕТЕСЛИ позволяет рассчитать число столбцов в строке с параметром А2 в ячейке, а вторая вычисляет это количество в таблице с параметром из В2. При равенстве результата «0» можно говорить, что в каждой ячейке столбца у этой сроки находятся уникальные параметры. При этом формула для Эксель выдает результат «Уникальная строка», а при их отсутствии «Не уникальная …».

Как найти дубликаты в Google Sheets

Первый способ сделать это — выделить дубликаты цветом. Вы можете искать дубликаты по столбцу и автоматически выделять их, заполняя ячейки или изменяя цвет текста.

Перед началом убедитесь, что ваша электронная таблица содержит данные, организованные по столбцам, и каждый столбец имеет заголовок.

Откройте таблицу, которую вы хотите проанализировать в Google Sheets.

Выделите столбец, который вы хотите найти.

Нажмите Формат > Условное форматирование . Условное форматирование откроется меню справа.

Убедитесь, что диапазон ячеек — это то, что вы выбрали на шаге 2.

В раскрывающемся списке « Формат ячеек, если …» выберите « Пользовательская формула» . Новое поле появляется под ним.

Введите следующую формулу в новом поле, корректируя буквы для выбранного диапазона столбцов:

В разделе Стиль форматирования выберите цвет заливки для дубликатов ячеек. В этом примере мы выбрали красный.

Вы также можете изменить цвет текста в дублирующих ячейках вместо того, чтобы заполнить его цветом. Для этого щелкните значок цвета текста ( A в строке меню) и выберите свой цвет.

Нажмите Готово, чтобы применить условное форматирование. У всех дубликатов теперь должна быть красная ячейка.

Поиск повторяющихся значений включая первые вхождения.

Предположим, что у вас в колонке А находится набор каких-то показателей, среди которых, вероятно, есть одинаковые. Это могут быть номера заказов, названия товаров, имена клиентов и прочие данные. Если ваша задача — найти их, то следующая формула для вас:

Где А2 — первая ячейка из области для поиска.

Просто введите это выражение в любую ячейку и протяните вниз вдоль всей колонки, которую нужно проверить на дубликаты.

Как вы могли заметить на скриншоте выше, формула возвращает ИСТИНА, если имеются совпадения. А для встречающихся только 1 раз значений она показывает ЛОЖЬ.

Подсказка! Если вы ищите повторы в определенной области, а не во всей колонке, обозначьте нужный диапазон и “зафиксируйте” его знаками $. Это значительно ускорит вычисления. Например, если вы ищете в A2:A8, используйте

Если вас путает ИСТИНА и ЛОЖЬ в статусной колонке и вы не хотите держать в уме, что из них означает повторяющееся, а что — уникальное, заверните свою СЧЕТЕСЛИ в функцию ЕСЛИ и укажите любое слово, которое должно соответствовать дубликатам и уникальным:

Если же вам нужно, чтобы формула указывала только на дубли, замените «Уникальное» на пустоту («»):

В этом случае Эксель отметит только неуникальные записи, оставляя пустую ячейку напротив уникальных.

Поиск неуникальных значений без учета первых вхождений

Вы наверняка обратили внимание, что в примерах выше дубликатами обозначаются абсолютно все найденные совпадения. Но зачастую задача заключается в поиске только повторов, оставляя первые вхождения нетронутыми. То есть, когда что-то встречается в первый раз, оно однозначно еще не может быть дубликатом.

Если вам нужно указать только совпадения, давайте немного изменим:

На скриншоте ниже вы видите эту формулу в деле.

Нетрудно заметить, что она не обозначает первое появление слова, а начинает отсчет со второго.

Чувствительный к регистру поиск дубликатов

Хочу обратить ваше внимание на то, что хоть формулы выше и находят 100%-дубликаты, есть один тонкий момент — они не чувствительны к регистру. Быть может, для вас это не принципиально. Но если в ваших данных абв, Абв и АБВ — это три разных параметра – то этот пример для вас.

Как вы могли уже догадаться, выражения, использованные нами ранее, с такой задачей не справятся. Здесь нужно выполнить более тонкий поиск, с чем нам поможет следующая функция массива:

Не забывайте, что формулы массива вводятся комбиинацией Ctrl + Shift + Enter.

Если вернуться к содержанию, то здесь используется функция СОВПАД для сравнения целевой ячейки со всеми остальными ячейками с выбранной области. Результат возвращается в виде ИСТИНА (совпадение) или ЛОЖЬ (не совпадение), которые затем преобразуются в массив из 1 и 0 при помощи оператора (—).

После этого, функция СУММ складывает эти числа. И если полученный результат больше 1, функция ЕСЛИ сообщает о найденном дубликате.

Если вы взглянете на следующий скриншот, вы убедитесь, что поиск действительно учитывает регистр при обнаружении дубликатов:

Смородина и арбуз, которые встречаются дважды, не отмечены в нашем поиске, так как регистр первых букв у них отличается.

голоса
Рейтинг статьи
Ссылка на основную публикацию
Adblock
detector